# Contents

<table>
<thead>
<tr>
<th>Section number</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Chapter 1</strong></td>
<td></td>
</tr>
<tr>
<td>1.1</td>
<td>Overview</td>
<td>7</td>
</tr>
<tr>
<td>1.2</td>
<td>Features</td>
<td>7</td>
</tr>
<tr>
<td>1.3</td>
<td>Benefits</td>
<td>8</td>
</tr>
<tr>
<td>1.4</td>
<td>Concepts</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td><strong>Chapter 2</strong></td>
<td></td>
</tr>
<tr>
<td>2.1</td>
<td>User Interface</td>
<td>0</td>
</tr>
<tr>
<td>2.2</td>
<td>Main Menu</td>
<td>11</td>
</tr>
<tr>
<td>2.2.1</td>
<td>Project Pop-up Menu</td>
<td>12</td>
</tr>
<tr>
<td>2.2.2</td>
<td>Processor Expert Options</td>
<td>12</td>
</tr>
<tr>
<td>2.2.2.1</td>
<td>Project Options</td>
<td>12</td>
</tr>
<tr>
<td>2.2.2.2</td>
<td>Preferences</td>
<td>13</td>
</tr>
<tr>
<td>2.3</td>
<td>Components View</td>
<td>15</td>
</tr>
<tr>
<td>2.3.1</td>
<td>View Menu</td>
<td>17</td>
</tr>
<tr>
<td>2.3.2</td>
<td>Popup Menu</td>
<td>17</td>
</tr>
<tr>
<td>2.4</td>
<td>Components Library View</td>
<td>19</td>
</tr>
<tr>
<td>2.4.1</td>
<td>Modes</td>
<td>19</td>
</tr>
<tr>
<td>2.4.2</td>
<td>Filtering</td>
<td>20</td>
</tr>
<tr>
<td>2.4.3</td>
<td>Pop-up Menu</td>
<td>20</td>
</tr>
<tr>
<td>2.4.4</td>
<td>Component Assistant</td>
<td>21</td>
</tr>
<tr>
<td>2.5</td>
<td>Component Inspector View</td>
<td>22</td>
</tr>
<tr>
<td>2.5.1</td>
<td>Read Only Items</td>
<td>23</td>
</tr>
<tr>
<td>2.5.2</td>
<td>View Mode Buttons</td>
<td>23</td>
</tr>
<tr>
<td>2.5.3</td>
<td>View Menu</td>
<td>23</td>
</tr>
<tr>
<td>2.5.4</td>
<td>Graphical Mode</td>
<td>24</td>
</tr>
<tr>
<td>2.5.5</td>
<td>Pop-up Menu</td>
<td>24</td>
</tr>
</tbody>
</table>

Processor Expert User Guide, Rev. 4.0, 08/2014

Freescale Semiconductor, Inc.
Section number | Title | Page
--- | --- | ---
2.5.6 | Inspector Items | 25
2.5.7 | Items Visibility | 27
2.5.8 | Configuration Inspector | 28
2.5.8.1 | Properties | 28
2.6 | Processor View | 29
2.6.1 | Control Buttons | 30
2.6.1.1 | Pins | 31
2.6.1.2 | Hints | 31
2.6.1.3 | Shared Pins | 32
2.6.1.4 | On-chip Peripherals | 32
2.6.1.4.1 | Peripheral or Pin Pop-up Menu | 33
2.7 | Memory Map View | 34
2.8 | Configuration Registers View | 34

Chapter 3
Using Processor Expert

3.1 | Create Project | 37
3.1.1 | Select Components | 37
3.1.2 | Configure Components | 38
3.1.3 | Verify Settings | 38
3.1.4 | Generate Code | 38
3.1.5 | Build and Debug | 39
3.2 | Basic Principles | 39
3.2.1 | Embedded Components | 39
3.2.1.1 | Easy Initialization | 40
3.2.1.2 | Easy On-chip Peripherals Management | 40
3.2.1.3 | Component Categories | 41
3.2.1.4 | Levels of Abstraction | 41
3.2.2 | SoC Components | 42
<table>
<thead>
<tr>
<th>Section number</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.3</td>
<td>Configuring Components</td>
<td>43</td>
</tr>
<tr>
<td>3.3.1</td>
<td>Configurations</td>
<td>43</td>
</tr>
<tr>
<td>3.3.2</td>
<td>Design Time Checking</td>
<td>43</td>
</tr>
<tr>
<td>3.3.3</td>
<td>Creating User Component Templates</td>
<td>44</td>
</tr>
<tr>
<td>3.3.4</td>
<td>Signal Names</td>
<td>45</td>
</tr>
<tr>
<td>3.3.4.1</td>
<td>Documentation</td>
<td>45</td>
</tr>
<tr>
<td>3.4</td>
<td>Component Inheritance and Component Sharing</td>
<td>46</td>
</tr>
<tr>
<td>3.4.1</td>
<td>Inheritance</td>
<td>47</td>
</tr>
<tr>
<td>3.4.2</td>
<td>Settings in Processor Expert</td>
<td>47</td>
</tr>
<tr>
<td>3.4.3</td>
<td>Component Sharing</td>
<td>48</td>
</tr>
<tr>
<td>3.4.4</td>
<td>Settings in Processor Expert</td>
<td>48</td>
</tr>
<tr>
<td>3.4.5</td>
<td>Run-time Resources Allocation</td>
<td>48</td>
</tr>
<tr>
<td>3.5</td>
<td>Sharing Pins Among Peripherals</td>
<td>49</td>
</tr>
<tr>
<td>3.5.1</td>
<td>ConnectPin Method</td>
<td>49</td>
</tr>
<tr>
<td>3.6</td>
<td>Export and Import</td>
<td>49</td>
</tr>
<tr>
<td>3.6.1</td>
<td>Export Component Settings</td>
<td>50</td>
</tr>
<tr>
<td>3.6.2</td>
<td>Export Board Configuration</td>
<td>52</td>
</tr>
<tr>
<td>3.6.3</td>
<td>Import Component Settings</td>
<td>54</td>
</tr>
<tr>
<td>3.6.4</td>
<td>Apply Board Configuration</td>
<td>57</td>
</tr>
<tr>
<td>3.6.5</td>
<td>Import Component(s) from Package</td>
<td>58</td>
</tr>
<tr>
<td>3.7</td>
<td>Code Generation and Usage</td>
<td>60</td>
</tr>
<tr>
<td>3.7.1</td>
<td>Files Produced by Processor Expert</td>
<td>60</td>
</tr>
<tr>
<td>3.7.2</td>
<td>Tracking Changes in Generated Code</td>
<td>61</td>
</tr>
<tr>
<td>3.8</td>
<td>PE Project File</td>
<td>62</td>
</tr>
<tr>
<td>3.8.1</td>
<td>Project Directory Structure</td>
<td>63</td>
</tr>
</tbody>
</table>
Chapter 1
Introduction

It describes how to get started with the Processor Expert tool.

The document also makes you familiar with the user interface of Processor Expert.

This chapter explains:

- Overview
- Features
- Benefits
- Concepts

1.1 Overview

Both hardware and software design have progressed with the ever-advancing new technologies emerging everyday, but their interrelationships and interdependence have been mostly neglected. On one hand, you often see a good new hardware architecture, but the software design is too expensive for such an architecture. On the other hand, the computerization of nearly all mechanical gadgets all over the modern world leads to the use of embedded computer systems. In situations where expense is a consideration, embedded computer systems with efficient software can significantly reduce the overall design cost. Processor Expert is designed for rapid application development of embedded applications for a wide range of processors.

1.2 Features

The key features of Processor Expert are:
• Includes a library of embedded system building blocks
• Created from Embedded Components
• Provides built-in SOC verification system for verifying component settings
• Supports automatic configuration management and data generation
• Easy to use graphical user interface
• Integrated into Eclipse environment

1.3 Benefits

The benefits of Processor Expert are:

• Embedded Components encapsulate the functionality of basic elements of embedded systems, such as CPU core, on-chip peripherals, FPGA, standalone peripherals, virtual devices, and pure software algorithms, and change these facilities to properties, methods, and events such as objects in OOP.
• The Peripheral Initialization components of Processor Expert generate effective initialization code for all on-chip devices and support all their features.
• Processor Expert allows easy examination of the details of the architecture and the relationship between the Embedded Component setup and processor's control registers initialization.

1.4 Concepts

Embedded device’s configuration or functionality is separated into building blocks called Embedded Components. The Processor Expert application is created from Embedded Components. These components generate a source code or data files for initialization and configuration of selected Freescale silicon. They have an interface similar to the object-oriented programming models that consists of:

• Properties - to modify or customize the object behavior. You can control properties in design time by using the Component Inspector.
• Methods (not used in this version) - the procedures that can be executed in application code and function calls.
• Events (not used in this version) - the interfacing hardware or software events which are invoked by the component to the user's code.
The Embedded Components have a subset called as Peripheral Initialization Components, which allow you to setup initialization of the particular on-chip device to any possible mode of operation. You can easily view all initialization values of the processor produced by Processor Expert with highlighted differences between the last and current properties settings.

Processor Expert performs a design time checking of the settings of all components and reports errors and warnings notifying you about wrong property values or conflicts in the settings with other components in the project.

Processor Expert contains many useful tools for exploring a structure of the target processor showing the details about the allocated on-chip peripherals and pins. It generates a ready-to-use code or the data files initializing all on-chip peripherals used by the component according to the component setup.
Chapter 2
User Interface

The Processor Expert menu is integrated as a plugin in the Eclipse IDE providing set of views.

The Eclipse IDE main menu has a menu item named Processor Expert.

The user interface of Processor Expert consists of the following views:

- Component Inspector - Allows you to setup components of the project.
- Component Library - Shows all supported components including processor components and component templates.
- Configuration Registers - Shows overview of the peripheral initialization settings for the current processor.
- Memory Map - Shows the processor address space and internal and external memory mapping.
- Components - Shows an embedded component that can be used in Processor Expert.
- Processor - The processor used in a given project.

This chapter explains:

- Main Menu
- Components View
- Components Library View
- Components Inspector View
- Processor View
- Memory Map View
- Configuration Registers View

2.2 Main Menu
The Processor Expert plugin is integrated into the Eclipse IDE as plugin application. The IDE main menu contains a new menu item named Processor Expert.

The Processor Expert menu includes:

- **Show views** - Shows standard Processor Expert windows in case they are hidden.
- **Hide views** - Hides Processor Expert views.
- **Import Component(s) from Package** - This command allows to select and install Processor Expert update packages (.PEUpd) files. These files can be created in CDE by exporting a user's component.

### 2.2.1 Project Pop-up Menu

This menu is available on right-clicking at the `ProcessorExpert.pe` file. It contains the standard commands with the Processor Expert specific command:

**Generate Processor Expert Code** - Invokes code generation for the current project. The generated files are automatically inserted into the active (default) target in the QorIQ Configuration project. Generated files corresponding to the Embedded Components can be accessed from the `Generated_Code` folder. For more details, refer to the Code Generation and Usage topic.

For Processor Expert related settings and options, refer to the Processor Expert Options.

### 2.2.2 Processor Expert Options

This section contains the following topics:

- **Project Options**
- **Preferences**

#### 2.2.2.1 Project Options

Project options related to Processor Expert can be found in Properties dialog box. To access this dialog box, click **Project > Properties**. The Properties dialog box appears.

Select **Processor Expert** option in the list on the left. Description of the individual options can be found in the hint window displayed when the cursor is placed on an item.
2.2.2.2 Preferences

Global settings related to Processor Expert can be found in Preferences dialog available using the command Window > Preferences. The PE related items can be found under Processor Expert in the list on the left. Description of the individual options can be found in the hint window displayed when the cursor is placed on an item.
There is an option *Preferred inspector views* that allows you to decide how to display the tabs of *Component Inspector* view. There are two views Custom and Classic.

To start or shutdown the processor expert, click *Windows > Preferences* and expand *General* and select *Startup and Shutdown*. Processor Expert starts after the Eclipse workbench user interface is displayed if the *Processor Expert Core* checkbox is selected as shown below.
2.3 Components View

To open this view, click Window > Show View > Other... and select Processor Expert > Components.

Components view shows the tree with the following items:

- **Generator_Configurations** - Configurations of the project.
• **Operating System** - contains special components that provide operating system interface and configuration if there are any used.

• **Processors** - contains processor components included in the project.

• **Components** - it is included in the project. Every component inserted in the project is displayed in the **Component Inspector** view and may have a sub tree showing items available for the component (note that components can offer only some or even none of these items):
  
  • **Methods** - Methods allow runtime control of the component's functionality.
  
  • **Events routines** - Events allow handling of the hardware or software events related to the component. If the event is disabled, the name of the event is shown. For enabled events, the name of the handling function is shown.
  
  • **ISRs** - Represent component-related interrupt routines that is created by you for low-level interrupt processing. For items, whose ISR names have been specified within component settings, a user-specified name of an ISR and name of the interrupt vector is shown. If an ISR name is not specified (interrupt has to be disabled in this case), only the interrupt vector name is present.

All component's items have status icons that signify the enabled or disabled state. If this state cannot be changed directly, the background of the icon is gray. For more details, refer to the **Embedded Components** topic.

This table explains the various states of a component.

<table>
<thead>
<tr>
<th>Component Status Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✓</td>
<td>Signifies that component is enabled. It can be configured and code can be generated from this component.</td>
</tr>
<tr>
<td>✗</td>
<td>Signifies that component is disabled. It can be configured, but the configuration validation/ generation is disabled. No code is generated from this component.</td>
</tr>
<tr>
<td>☞</td>
<td>Signifies error in the component. For example, Components folder contains component with error.</td>
</tr>
<tr>
<td>✽</td>
<td>Signifies that component is frozen and will not be re-generated. When the user generates the code again, files of this component are not modified and the generated code is frozen.</td>
</tr>
</tbody>
</table>

Shared components are automatically placed into a dedicated subfolder **Referenced_Components**. You can move the component from this folder to anywhere.
When you have more than one Processor Expert project in your workspace and you are working with those projects, the last project shown in Components view is recorded in the workspace history. When you restart the Eclipse IDE, the last session project is opened automatically.

### 2.3.1 View Menu

- **Generate Processor Expert Code** - invokes code generation for the current project.
- **Close/Open Project** - closes the project if it is open or opens the project if it is closed.
- **Properties** - displays the Processor Expert properties for a specific project.
- **Export** - allows to export component settings or configuration of selected Processor Expert components.
- **Import** - allows to import component settings or configuration of selected Processor Expert components.

### 2.3.2 Popup Menu
• **Inspector** - opens **Component Inspector** view for the component. For more details, refer to the Component Inspector View topic.

• **Inspector - Pinned** - opens **Component Inspector** view for the component in "pinned" mode. This command allows to have several inspector views for different components opened at once. For more details, refer to the Component Inspector View topic.

• **Code Generation** - allows to disable/enable the generated module for the component and CPU component.

• **Configuration Registers** - displays the Configuration Registers view for the peripheral initialized by the selected component. For more details, refer to the Configuration Registers View topic.

• **Target Processor Package** - displays the Processor view for the processor derivative used in a given project.

• **Processor Memory Map** - displays the Memory Map view for the processor address space and internal and external memory mapping.

• **Rename Component** - changes the name of the component.

• **Select Distinct/ Shared mode** - switches between shared and distinct mode of the component. This setting is available for LDD components only.

• **Open File** - opens the generated code from the selected component for the source code editor. Note that the code is available only after successful code generation.

• **Component Enabled** - enables/disables component in the project.

• **Copy/Paste** - components can be copied and pasted inside the same project, between two projects in the same workspace, and between two projects having each project in separate workspace.

• **Remove component from project** - deletes the component from the project.

• **Help on component** - shows a help page for the component.

• **Save Component Settings As Template** - creates a template of the selected component. For more details, refer to the Creating User Component Templates topic.

• **Hot key** **Delete** is used for deleting components from the project.

• **View Code** - Opens code editor at the code of the selected method or event.

• **Toggle Enable/Disable** - Enables/Disables the Method or Event.
2.4 Components Library View

This view allows you to select a component and add it to the project. To open this view, click Window > Show View > Other... and select Processor Expert > Components Library.

The Components Library view shows supported embedded components including processor components and component templates. It lets you select a desired component or template and add it to the project.

2.4.1 Modes

The Components Library has the following four tabs allowing you to select components in different modes:

- **Categories** - Contains all available components. The components are sorted in a tree based on the categories defined in the components. For more details, refer to the Component Categories topic.
- **Alphabetical** - Shows alphabetical list of the available components.
- **Assistant** - Guides you during the component selection process. The user answers a series of questions that finally lead to a selection of a component that suits best for a required function. For more details, refer to the Component Assistant topic.
- **Processors** - Contains list of the available processors.
Component names are colored black and the component template names are colored blue. The components that are not supported for the currently selected target processor are gray. By double-clicking on the component, it is possible to insert the component into the current project. The description of the component is shown in a hint.

### 2.4.2 Filtering

You can activate or deactivate the filtering icon.

Filter can be activated using the filtering icon. If it is active, only the components that could be used with the currently selected target processors are shown.

If the filter is inactive, Processor Expert also shows components that are not available for the current processor.

### 2.4.3 Pop-up Menu

A pop-up menu opens by right-clicking a component or folder. It contains the following commands:

- **Add to project** - Adds the component to the current project.
- **Add to project with wizard** - Adds the component to the current project and opens a configuration wizard.
- **Expand all** - Expands the folder and all its subfolders.
- **Collapse all** - Collapses the folder and all its subfolders.
- **Refresh** - Refreshes the view area.
- **Delete** - Only user templates and components are deleted. User component is deleted from the User Working Directory, from the Beans sub-directory. See Processor Expert Eclipse console for the location of the User Working Directory. Other files like *.inc, *.drv, *.src remain intact.
- **Help on component** - Opens help information for the selected component.
2.4.4 Component Assistant

It guides you during the selection of components while creating basic application building blocks.

The Component Assistant is a mode of Components Library view. You will have to answer a series of questions that finally lead to a selection of a component that suits best for a required function. In this mode, the Components Library view consists of the following parts:

- History navigation buttons and the history line showing answers for already answered questions. You can walk through the history using the arrow buttons or by clicking the individual items.
- A box with a current question.
- A list of available answers for the current question.

If the answer already corresponds to a single component (it has an icon of the component and there is a [component name] at the end of the list line) and user double-clicks it, it is added into the project. Also, you can right-click on the line to open the pop-up menu of the component, allowing to add it into the project or view its documentation (for details, refer to the Components Library View topic).
If more questions are necessary for the component selection, the line with the answer contains a group icon and in brackets a number of components that still can possibly be selected. After clicking on such line a next question is displayed.

This mode of Components Library does not offer addition of processor components. If you would like to add another processor component, switch to processors tab.

2.5 Component Inspector View

To open this view, click Window > Show View > Other... and select Processor Expert > Components Inspector.

Inspector window contains three columns:

- **Name** - Name of the item to be selected. Groups of items may be collapsed or expanded by double clicking on the first line of the group with its name, it has '+' or '-' sign on the left.
- **Value** - the settings of the items are made in this column. For list of item types, refer to the Inspector Items topic for details.
- **Details** - the current setting or an error status may be reflected on the same line, in the rightmost column of the inspector.

![Component Inspector View](image)

**Figure 2-7. Component Inspector View - Displaying Pin variant and Package**
2.5.1 Read Only Items

The values that are read-only appear in gray.

Some items are read-only so you can not change the content. Such values are gray.

2.5.2 View Mode Buttons

The buttons will allow you to switch to the complex view of the component's items.

They are placed at the top of the window (Basic, Advanced, Expert). Refer to the Items Visibility topic for details.

2.5.3 View Menu

The View menu of Component Inspector is invoked by clicking on the down-arrow icon.

The menu contains the following options:

- **Basic, Advanced, Expert** - view mode switching. These options have the same meaning as the view mode buttons.
- **Ignore Constraints and non-Critical Errors** - this option enables a special mode of Processor Expert. In this mode, Processor Expert allows you to generate output files, even though some settings may break some constraints or limits and errors are reported. The mode also allows you to set some enumeration of numeric properties to a custom value out of allowed range. Use the Graphical Mode of Component Inspector to enter the custom value.
- **Expand All** - if a group is selected, expands all items within the selected group. Otherwise, all groups in the Inspector are expanded. If the expanded group contains any groups that are disabled (gray), the user is asked if the disabled groups should all be expanded.
- **Collapse All** - if a group is selected, collapses all items within the selected group. Otherwise, all groups in the Inspector are collapsed.
- **Help on Component** - shows a help page for the component.
- **Save component settings as template** - creates a template for the current component settings. Refer to the Creating User Component Templates topic for details.
• **Open pinned view** - opens a copy of the inspector for currently selected component. This command allows to have several inspector views for different components opened at once.

• **Search** - searches Inspector item by name. It also accepts wild cards like * or ? (* = any string and ? = any character).

### 2.5.4 Graphical Mode

The graphical mode can be switched on/off using the Graphical Mode toolbar button. When you click on the **Graphical Mode** button, the inspector view is split into two panels. The left contains a list of items (properties) and the right one allows an alternative way of editing the property selected on the left.

![Component Inspector with Graphical Mode On](image)

Figure 2-8. Component Inspector with Graphical Mode On

### 2.5.5 Pop-up Menu

The Pop-up menu is invoked by right-clicking a specific Component Inspector item. The menu contains the following options:

• **Expand All** - if a group is selected, expands all items within the selected group. Otherwise, all groups in the inspector are expanded. If the expanded group contains any groups that are disabled (gray), the user is asked if the disabled groups should all be expanded.
• **Collapse All** - if a group is selected, collapses all items within the selected group. Otherwise, all groups in the inspector are collapsed.
• **Help on Component** - shows a help page for the component.
• **Delete Item** - does not delete the component, but can delete the property item from the list of property. The list of items can have some constraints on minimal or maximum number of items. Add ADC component into the project and add at least one extra channel then you will be able to see this option enabled as shown below.

![Figure 2-9. Delete Item](image)

- **Pin Sharing Enabled** - enables the pin sharing. This command is available only for pin properties. For more information, refer to the Sharing Pins Among Peripherals topic.

### 2.5.6 Inspector Items

The following types of the items are there in the **Component Inspector** view.

![Figure 2-10. Example Component with Various Inspector Item Types](image)
This table explains the various types of items.

### Table 2-2. Inspector Item Types

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boolean Group</td>
<td>A group of settings controlled by this boolean property. If the group is enabled, all the items under the group are valid; if it is disabled, the list of items is not valid. Clicking + sign will show/hide the items in the group but doesn't affect value or validity of the items.</td>
</tr>
<tr>
<td>Boolean yes/no</td>
<td>You can switch between two states of the property using a drop-down menu. The Generate code/Don't generate code settings of methods and events works the same way and determines whether the implementation code for the corresponding method or event will be generated or not (you may thus generate only the methods and events used by your application).</td>
</tr>
<tr>
<td>Enumeration</td>
<td>Selection from a list of values. If you click the arrow icon ( ), a list of the possible values for the property is offered. For some derivatives, pin and package details are displayed for processor variant.</td>
</tr>
<tr>
<td>Enumeration Group</td>
<td>A list of items. Number of visible (and valid) items in the group depends on chosen value. Clicking the arrow icon ( ) will show a list of the possible values of the property. Clicking the + sign shows/hides the items in the group but does not influence value or validity of the items.</td>
</tr>
<tr>
<td>File/Directory Selection</td>
<td>Allows to specify a file or directory. Clicking the icon opens a system dialog window allowing to select a file/directory.</td>
</tr>
<tr>
<td>Group</td>
<td>A list of items that can be expanded/collapsed by clicking on the plus/minus icon or by double-clicking at the row. Values of the items in the group are untouched.</td>
</tr>
<tr>
<td>Integer Number</td>
<td>You can insert a number of a selected radix. Radix of the number could be switched using the icons (D = Decimal, H = Hexadecimal, B = Binary). Only reasonable radixes are offered for the property. If the radix switching icon is not present, Processor Expert expects the decimal radix.</td>
</tr>
<tr>
<td>Link to Inherited component</td>
<td>The down-arrow button allows to change the ancestor from the list of possible ancestor. Refer to the Component Inheritance and Component Sharing topic for details.</td>
</tr>
<tr>
<td>Link to shared component</td>
<td>The down-arrow button allows to change the component from the list of the available components or add a new component to the project. Refer to the Component Inheritance and Component Sharing topic for details.</td>
</tr>
<tr>
<td>List of items</td>
<td>A list of items may be expanded/collapsed by clicking on the plus/minus button in the left side of the row or by double clicking on the row. You may add/remove items by clicking on the plus/minus button. The items in the list can be arranged using the Pop-up Menu related commands.</td>
</tr>
<tr>
<td>Peripheral selection</td>
<td>You can select a peripheral from the list of the available peripherals. The peripheral that are already allocated have the component icon in the list. The properties that conflicts with the component settings have the red exclamation mark.</td>
</tr>
<tr>
<td>Real Number</td>
<td>You can insert any real (floating point) number.</td>
</tr>
</tbody>
</table>
Table 2-2. Inspector Item Types (continued)

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>String</td>
<td>Allows to enter any text or value. If there are no recommended values specified, there is no change in the user interface. If the values are specified, these values helps user to select typical or recommended value for the property. This feature is supported for String and Real Number properties. The recommended values used for the property are ONE, TWO, and THREE. The string property can offer predefined values accessible hitting key stroke <code>ctrl+space</code>. You can see that this is available when the string value is edited and there are predefined values available, small yellow bulb is displayed before top-left corner of edit field.</td>
</tr>
<tr>
<td>String list</td>
<td>Clicking the browse button (...) opens the simple text editor that allows to enter an array of text lines.</td>
</tr>
<tr>
<td>Time, Date</td>
<td>Allows to setup the Time/Date in a format according to the operating system settings.</td>
</tr>
<tr>
<td>Timing settings</td>
<td>Allows a comfortable setting of the component's timing. The timing dialog box opens on clicking on browse button (...).</td>
</tr>
</tbody>
</table>

2.5.7 Items Visibility

The Processor Expert supports three visibility levels of the component items.

Each item is assigned a predefined level of visibility. **Higher visibility level** means that items with this level are more special and rarely used than the others with the lower visibility level. Component Inspector displays only items on and below the selected level. It could help especially beginners to set only basic properties at first and do optimization and improvements using advanced and expert properties or events later. There are three visibility levels:

- **Basic view** - The key and most often used items that configure the basic functionality of the components.
- **Advanced view** - All items from Basic view and the settings that configure some of more advanced and complex features of the component.
- **Expert view** - Maximum visibility level - All possible settings, including all settings of basic and advanced view.

The visibility can be switched in the Component Inspector View using Basic, Advanced, and Expert buttons or within its view menu.
NOTE
If an error occurs in a property with a higher visibility level than the level currently selected, then also this error is displayed.

2.5.8 Configuration Inspector

It is a variant of Component Inspector.

It displays the settings of a selected component. It could be invoked from configurations pop-up menu in the Components view (click on a configuration with the right-button and choose the Configuration Inspector). For details on configurations, refer to the Configurations topic.

2.5.8.1 Properties

The Properties tab of Component Inspector contains optimization settings related to the configuration.

These settings should be used when the code is already debugged. It could increase speed of the code, but the generated code is less protected for the unexpected situations and finding errors could be more difficult.

Note that some of the options may not be present for all Processor Expert versions.

• **Ignore range checking** - This option can disable generation of the code that provides testing for parameter range. If the option is set to yes, methods do not return error code ERR_VALUE neither ERR_RANGE. If the method is called with incorrect parameter, it may not work correctly.

• **Ignore enable test** - This option can disable generation of the code that provides testing if the component/peripheral is internally enabled or not. If the option is set to yes, methods do not return error code ERR_DISABLED neither ERR_ENABLED. If the method is called in unsupported mode, it may not work correctly.

• **Ignore speed mode test** - This option can disable generation of the code, that provides a testing, if the component is internally supported in the selected speed mode. If the option is set to yes, methods do not return error code ERR_SPEED. If the method is called in the speed mode when the component is not supported, it may not work correctly.
• **Use after reset values** - This option allows Processor Expert to use the values of peripheral registers which are declared by a chip manufacturer as default after reset values. If the option is set to no, all registers are initialized by a generated code, even if the value after reset is the same as the required initialization value. If the option is set to yes, the register values same as the after reset values are not initialized.

• **Complete initialization in Peripheral Init. Component** - This option can disable shared initialization peripheral in Init methods of Peripheral Initialization Components. If this option is set to yes, the complete peripheral initialization is provided in Init method, even for parts that are already initialized in processor or elsewhere. It could mean longer code, but the initialization can be repeated in application using the Init method.

### 2.6 Processor View

It allows you to generate code from processor and also to switch the processor's package. To open this view, click **Window > Show View > Other...** and select **Processor Expert > Processor**.
2.6.1 Control Buttons

The following table lists and describes the control buttons:

Table 2-3. Control Buttons

<table>
<thead>
<tr>
<th>Buttons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom in - Increases the detail level of the view. The whole picture might not fit the viewing area.</td>
<td></td>
</tr>
</tbody>
</table>

*Table continues on the next page...*
### Table 2-3. Control Buttons (continued)

<table>
<thead>
<tr>
<th>Buttons</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Zoom out" /></td>
<td>Zoom out - Decreases the detail level of the view. Processor Expert tries to fit the whole picture to the viewing area.</td>
</tr>
<tr>
<td><img src="image" alt="Rotate" /></td>
<td>Rotate - Rotates the package clockwise.</td>
</tr>
<tr>
<td><img src="image" alt="Resources" /></td>
<td>Resources <em>(available for BGA type packages only)</em> - Selects Resources view mode that shows a top side of the package without pins but including list of peripherals and showing their allocation by components.</td>
</tr>
<tr>
<td><img src="image" alt="Pins Bottom" /></td>
<td>Pins Bottom <em>(available for BGA type packages only)</em> - Selects Pins view mode that shows a bottom side of the package with pins. The peripherals are not shown in this mode because the surface is covered with pins.</td>
</tr>
<tr>
<td><img src="image" alt="Pins Top" /></td>
<td>Pins Top - Select Pins view mode that shows a top side of the package with pins.</td>
</tr>
</tbody>
</table>

---

### 2.6.1.1 Pins

It gives information about each pin that is displayed on the processor.

The following information about each pin: (in case of BGA type package the pins are displayed only in the Pins view mode)

- pin name (default or user-defined)
- icon of a component that uses (allocates) the pin
- direction of the pin (input, output, or input/output) symbolized by blue arrows if a component is connected
- With new pin model (supported for few derivatives only), the background color of the pin reflects routing of the pin to the peripheral.

Pin names are shortened and written either from left to right or from top to bottom and are visible only if there is enough space in the diagram.

Some signals and peripherals cannot be used by the user because they are allocated by special devices such as power signals, external, or data bus. The special devices are indicated by a special blue icons. The allocation of peripherals by special devices can be influenced by processor component settings.

In case of BGA package, the pins that are used by some component are colored yellow. Move the cursor on the pin to get detailed information.
2.6.1.2  Hints

It displays the basic information about the pin.

**Pin hint** contains:

- number of the pin (on package)
- both names (default and user-defined)
- owner of the pin (component that allocates it)
- short pin description from processor database

**Component icon** hint contains:

- component name
- component type
- component description

2.6.1.3  Shared Pins

It explains how a pin is shared among peripherals.

If a pin is shared by multiple components, the line connecting the pin to the component has a red color. Refer to the [Sharing Pins Among Peripherals](#) topic for details.

2.6.1.4  On-chip Peripherals

The basic information about each on-chip peripheral is displayed on the processor package.

The following information is displayed on the processor package:

- peripheral device name (default or user-defined)
- icon of the component that uses (allocates) the peripheral device

Peripheral device hint contains:

- peripheral device name
- owner of the pin (component that allocate it)
- short peripheral device description

Hint on icon contains:
• component name
• component type
• component description

If a peripheral is shared by several components (for example, several components may use single pins of the same port), the icon is displayed.

NOTE
Some peripherals work in several modes and these peripherals can be represented by a several devices in the processor databases. For example, the device TimerX_PPG and TimerX_PWM represents TimerX in the PPG and PWM mode. These devices can be displayed on the processor package, but they are also represented as a single block in the microcontroller block diagram.

2.6.1.4.1 Peripheral or Pin Pop-up Menu

It displays peripheral or pin specific pop-up options.

The following options are available in the pop-up menu:

• **Show Peripheral Initialization** - Shows initialization values of all control, status, and data registers. This option is supported for all devices displayed on a processor package. Refer to the [Configuration Registers View](#) topic for details.
• **Zoom in** - Increases the detail level of the view. The whole picture might not fit the viewing area.
• **Zoom out** - Decreases the size of the picture and detail level of the view.
• **Rotate** - Rotates the package by 90 degrees.
• **Add Component/Template** - Adds a component or template for the appropriate peripheral; all available components and templates suitable for the selected peripheral are listed. The components and templates in the list are divided by a horizontal line. It is possible to add only components or templates which are applicable for the peripheral. It means that is possible to add the component or template only if the peripheral is not already allocated to another component or components. The components/templates that cannot be added to the peripheral are grayed in the pop-up menu as unavailable. This option is supported for all devices displayed on processor package.
• **Remove Component** - Allows to remove all components allocating peripheral in Processor view. Processor component cannot be removed.
2.7 Memory Map View

To open this view, click Window > Show View > Other... and select Processor Expert > Memory Map.

Figure below shows the processor address space and internal and external memory mapping. Detailed information for an individual memory area is provided as a hint when you move the cursor over it.

Table 2-4. Legends

<table>
<thead>
<tr>
<th>Legend</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="White" /></td>
<td>white: non-usable space</td>
</tr>
<tr>
<td><img src="image" alt="Dark Blue" /></td>
<td>dark blue: I/O space</td>
</tr>
<tr>
<td><img src="image" alt="Blue" /></td>
<td>blue: RAM</td>
</tr>
<tr>
<td><img src="image" alt="Light Blue" /></td>
<td>light blue: ROM, OTP or Firmware</td>
</tr>
<tr>
<td><img src="image" alt="Cyan" /></td>
<td>cyan: FLASH memory or EEPROM. This area can also contain a flash configuration registers area.</td>
</tr>
<tr>
<td><img src="image" alt="Black" /></td>
<td>black: external memory</td>
</tr>
</tbody>
</table>

The address in the diagram is increasing upwards. To improve the readability of the information, the size of the individual memory blocks drawn in the window are different from the ratio of their real size (small blocks are larger and large blocks are smaller).

The black line-crossed area shows the memory allocated by a component or compiler. The address axis within one memory block goes from the left side to the right (it means that the left side means start of the block, the right side means the end).

![Figure 2-12. Sample of Used Part of the Memory Area](image)

2.8 Configuration Registers View

It displays initialization values of all control, status, and data registers of selected peripheral/device including single bits. The values are grouped into two parts: Peripheral registers containing registers directly related to the selected peripheral/device and Additional registers containing the registers that are influenced by the component but
are not listed for the peripheral currently selected in this view. To open this view, click Window > Show View > Other... and select Processor Expert > Configuration Registers.

The initialization information reflects:

- Processor default settings - When the peripheral is not utilized by any Embedded Component.
- Embedded Component settings - When the peripheral is utilized by an Embedded Component and the component settings are correct. Peripheral Initialization Inspector shows initialization as required by the component settings.

![Figure 2-13. Configuration Registers View](image)

The table shows the registers and their initialization value displayed in the column \textit{Init. value}. You can modify the register value. Registers value can be changed if:

- They are not read-only and when the project is without errors
- Editing of configuration registers is supported by given component

This value written into the register or bit by the generated code during the initialization process of the application. It is the last value that is written by the initialization function to the register. The \textit{After reset} column contains the value that is in the register by default after the reset.

The values of the registers are displayed in the hexadecimal and binary form. In case the value of the register (or bit) is not defined, an interrogation mark "?" is displayed instead of the value. The \textit{Address} column displays the address of registers.

\textbf{NOTE}

For some registers, the value read from the register after sometime can be different than the last written value. For example, some interrupt flags are cleared by writing 1. For details, refer to the processor manual on registers.
In case the peripheral is allocated by a component and the setting of the component is incorrect, the initialization values are not displayed in the **Configuration Registers** view.
Chapter 3
Using Processor Expert

It explains how to start using the Processor Expert tool and Embedded Components.

The Processor Expert menu is integrated as a plugin in the Eclipse IDE providing set of views.

This chapter explains:

- Create Projects
- Basic Principles
- Configuring Components
- Component Inheritance and Component Sharing
- Export and Import
- Code Generation and Usage
- Processor Expert Files and Directories

3.1 Create Project

To create a new project, select File > New > QorIQ Configuration Project from the Eclipse IDE menu bar. Follow the steps in the New QorIQ Configuration Project wizard that appears, and select a processor you want to use. For details on creating a new Processor Expert project, refer to the QorIQ Configuration Suite Getting Started Guide.

The Processor Expert views can be opened any time using the menu command Processor Expert > ShowViews.

3.1.1 Select Components
The components to be used are selected in the **Components Library** view. You can add the selected component into the project by right-clicking on it and selecting the Add to project option from the pop-up menu. The component gets added to the Embedded Components folder of the Components view.

For details on individual components, see tooltip which is displayed when cursor is placed on the component or use the pop-up menu command Help on component.

### 3.1.2 Configure Components

The component to be configured is selected in the Components view. The component gets opened in the Component Inspector, refer to the **Component Inspector View** section. For details on how to configure components, refer to the **Configuring Components** and also refer to the user guide of each component.

### 3.1.3 Verify Settings

The Processor Expert errors, warnings, and status on project, code generations and Embedded Components settings are displayed within a standard Eclipse Problems view. If it is not open, select **Window > Show View > Other > General > Problems**.

The content of the view is continuously updated with the recent status. All error messages disappear when a project contains no settings with error. Double-clicking on an item takes you to the place where the particular problem occurred.

![Figure 3-1. Problems View](image-url)
3.1.4 Generate Code

Select **Project > Generate Processor Expert Code** from the Eclipse IDE menu bar or the icon at the top of the Components view to generate the code.

![Generating code](image)

**Figure 3-2. Generate Code**

The generated code is placed in the **Generated_Code** folder of the **Components** view. You can start using it in your application.

3.1.5 Build and Debug

When you are done with the application creation, build it and run it on the target.

3.2 Basic Principles

The application created in Processor Expert is built from the building blocks called Embedded Components. The following sections describe the features of the Embedded Components and the SoC components.

- **Embedded Components**
- **SoC Components**
3.2.1 Embedded Components

Embedded Components encapsulate the initialization and functionality of embedded systems basic elements, such as processor core, on-chip peripherals, FPGAs, standalone peripherals, virtual devices, and pure software algorithms. These facilities are displayed through properties, methods and events. It is very similar to objects in the Object Oriented Programming (OOP) concept.

3.2.1.1 Easy Initialization

You can initialize components by setting their initialization properties in the Component Inspector. Processor Expert generates the initialization code for the peripherals according to the properties of the appropriate components. You can decide whether the component will be initialized automatically at startup or manually by calling the component's `Init` method.

3.2.1.2 Easy On-chip Peripherals Management

Processor Expert knows exactly the relation between the allocated peripherals and the selected components. When you select a peripheral in the component properties, Processor Expert proposes all the possible candidates but signals the peripherals, which are allocated already, using the icon of the component allocating the peripheral. Processor Expert also signalizes the peripherals that are not compatible with the current component settings with a red exclamation mark. In case of an unrealizable allocation, an error is generated. Unlike common libraries, Embedded Components are implemented for all possible peripherals with optimal code. The most important advantages of the generated modules for driving peripherals are that you can:

- Select any peripheral that supports component function and change it whenever you want during design time.
- Be sure that the component setting conforms to peripheral parameters.
- Choose the initialization state of the component.
- Choose which methods you want to use in your code and which event you want to handle.
- Use several components of the same type with optimal code for each component.
The concept of the peripheral allocation generally does not enable sharing of peripherals because it would make the application design too complicated. The only way to share resources is through the components and their methods and events. For example, it is possible to use the RTI shared component for sharing periodic interrupt from timers.

3.2.1.3 Component Categories

The complete list of the component categories and corresponding components can be found in the Categories tab of the Components Library view (refer to the Components Library View section).

3.2.1.4 Levels of Abstraction

Processor Expert provides components with two several of abstraction and configuration comfort.

- High Level Components - components that are the basic set of components designed carefully to provide functionality to most microcontrollers in market. An application built from these components can be easily ported to another microcontroller supported by Processor Expert. This basic set contains, for example, components for
  - simple I/O operations, such as BitIO, BitsIO, ByteIO, ...,  
  - timers, such as EventCounter, TimerInt, FreeCntr, TimerOut, PWM, PPG, Capture, WatchDog,  
  - communication, such as AsynchroSerial, SynchroMaster, SynchroSlave, AsynchroMaster, AsynchroSlave, IIC,  
  - ADC,  
  - internal memories. This group of components allows comfortable settings of a desired functionality such as time in ms or frequency in Hz without letting you know about the details of the hardware registers. The processor specific features are supported only as Processor specific settings or methods and are not portable.
- Low Level Components - components that are dependent on the peripheral structure to allow you to benefit from the non-standard features of a peripheral. The level of portability is decreased due to a different component interface and the component is usually implemented only for a processor family offering the appropriate peripheral. However, you can easily set device features and use effective set of methods and events.
- Peripheral Initialization Components - components that are on the lowest level of abstraction. An interface of such components is based on the set of peripheral control
registers. These components cover all features of the peripherals and are designed for initialization of these peripherals.

• Device Configuration - components that can produce various data, for example, configuration files, for configuring functional blocks of processors or operating system.

**NOTE**

This version provides only Device Configuration components.

The features of components at different level of abstraction are described in table below.

<table>
<thead>
<tr>
<th>Feature</th>
<th>High level</th>
<th>Low level</th>
<th>Peripheral Init</th>
<th>Device Configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>High-level settings portable between different processor families</td>
<td>yes</td>
<td>partially</td>
<td>no</td>
<td>partially</td>
</tr>
<tr>
<td>Portable method interface for all processor families</td>
<td>yes</td>
<td>partially (usually direct access to control registers)</td>
<td>Init method only</td>
<td>no</td>
</tr>
<tr>
<td>Processor specific peripheral features support</td>
<td>partially</td>
<td>mostly yes</td>
<td>full</td>
<td>yes</td>
</tr>
<tr>
<td>Low-level peripheral initialization settings</td>
<td>no</td>
<td>partially</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Speed mode independent timing</td>
<td>yes</td>
<td>mostly yes</td>
<td>no</td>
<td>no</td>
</tr>
<tr>
<td>Events support</td>
<td>yes</td>
<td>yes</td>
<td>no (direct interrupt handling)</td>
<td>no</td>
</tr>
<tr>
<td>Software emulation of a component function (if the specific hardware is not present)</td>
<td>yes</td>
<td>no</td>
<td>no</td>
<td>no</td>
</tr>
<tr>
<td>Support for RTOS drivers creation</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>no</td>
</tr>
</tbody>
</table>

### 3.2.2 SoC Components

A SoC component is an Embedded Component encapsulating one processor type. A Processor Expert project may contain one or more SoC components. The processors included in a project are displayed in the Processors folder of the Components view. It is possible to switch among the SoC component, but only one of the SoC can be active at one time.
3.3 Configuring Components

Configuring the components in the project is one of the main activities in Processor Expert. It affects the initialization, run-time behavior and range of functionality available to the user of the generated code.

The following sections describe how to configure the Embedded Components used in the project correctly and effectively.

- Configurations
- Design Time Checking
- Creating User Component Templates
- Signal Names

3.3.1 Configurations

Every configuration keeps the enable/disable state of all components in the project; it does not keep any component settings. If you enable/disable a component in the project, the component state is updated in the currently selected configuration. If you create a new configuration, the current project state is memorized.

The configurations of the current project are listed in the Configurations folder of the Components view. The configurations can also hold additional settings that may influence code generation and can be changed in the Configuration Inspector. Refer to the Configuration Inspector section.

NOTE
It is possible to have two components with the same name in the project. Each of the components could be enabled in different configuration. This way you can have different setup of a component (a component with the same name) in multiple configurations.

3.3.2 Design Time Checking
During project design time, Processor Expert performs instant checking of the project. As a result of this checking, the error messages may appear in the Problems view or directly in the third column of the Component Inspector. Sometimes it may happen that only one small change in the project causes error messages.

### 3.3.3 Creating User Component Templates

If you frequently use a component with some specific settings, you may need to save the component with its settings as a template. This template is displayed in the Components Library view, behaves as a normal component and could be added to any project. The template has the same properties as the original component. The values of the properties are preset in the template and could be marked as read only.

To create a component template and save it:

1. Open the pop-up menu of the required component in the Components view and select the Save Component Settings as Template option. Alternatively, you can use the Component Inspector view; open the view menu using the icon at the top right corner, and select Save Component Settings as Template.
2. In the Component Template dialog box, fill in the appropriate details of the template.

![Component Template](image)

**Figure 3-3. Save Template**

3. Click OK. The template appears in the Components Library view and can be inserted into projects. Make sure that you refresh the Components Library view by selecting the Refresh option from pop-up menu.
3.3.4 Signal Names

The main purpose of the signals is to allow you to name the pins used by components with names corresponding to the application.

A signal name can be assigned to an allocated pin by specifying the signal name into the appropriate property (for example, Pin_signal) in the component properties (available in Advanced view mode). A signal name is an identifier that must start with a letter and rest of the name must contain only letters, numbers, and underscore characters.

For the components that allocate a whole port, such as ByteIO, there are two options:

- Assign a same signal name to all pins of port by writing the name into the Port signal property. Processor Expert automatically assigns this name extended with a bit number suffix to each of the individual pins.
- Assign a different signal name to individual pins by writing pin signal names (from the lowest bit to the highest one) separated by commas or spaces into the Port signal property.
3.3.4.1 Documentation

Processor Expert automatically generates a document ProcessorExpert_SIGNALS.txt containing a list of relationship between defined signals and corresponding pins. There is an additional signal direction information added next to each signal name and pin number information next to each pin name.

This document is available in the Documentation folder of the Components view. A sample of generated signals documentation is shown below.

![Figure 3-6. Document Containing Signals Details](image)

3.4 Component Inheritance and Component Sharing
**Ancestor** is a component that is inherited (used) by another component.
**Descendant** is a new component that inherits (uses) another component(s).
**Shared Ancestor** is a component that can be used and shared by multiple components.

### 3.4.1 Inheritance

Inheritance in Processor Expert means that an ancestor component is used only by the descendant component. Inheritance is supported in order to allow components to access peripherals by hardware-independent interface of the ancestor components. For example, a component that emulates a simple I2C transmitter may inherit two BitIO components for generation of an output signal.

On several complex components inheritance is used to separate component settings into several logical parts, for example, settings of channel is inherited in the component with settings of the main peripheral module.

### 3.4.2 Settings in Processor Expert

The Descendant component contains a property that allows selecting an ancestor component from a predefined list of templates. The component is created after selection of an appropriate template name (or component name) from the list of the templates fitting the specified interface. Any previously used ancestor component is discarded.

![Figure 3-7. Inherited Component Item in Inspector](image)

Processor Expert allows you to select from ancestors that implement the required interface and are registered by the descendant component.

The ancestor component is displayed under its descendant in the project structure tree in the **Components** view.

![Figure 3-8. Example of Ancestor and Descendant Components in the Components view](image)
An ancestor component requires a list of methods and events (interface), which must be implemented by an ancestor component. The error is shown if the ancestor component does not implement any of them. For example, if the settings of the descendant component do not allow it to generate this method.

3.4.3 Component Sharing

Component sharing allows you to cause several components to use capability of one component similar to inheritance. This feature allows sharing of its resources and its drivers with other components. For example, components may share an I2C component for communication with peripherals connected to the I2C bus or some component may do DMA transfers using DMA component.

3.4.4 Settings in Processor Expert

A shared ancestor component contains a property that allows you to select existing shared ancestor component or create a new one. In this case, the ancestor component is included in the project tree as the other components. The ancestor component may be used with the descendant component only if it is created from a template registered in the descendant component or if the component type is registered in the descendant component. It is recommended that you always create a shared ancestor component through a descendant component.

3.4.5 Run-time Resources Allocation

Processor Expert (generated code) does not check the usage of shared resources/code. It's up to you to ensure the correct run-time resources allocation of a shared ancestor component. Often, it is not possible for a shared ancestor component to be used simultaneously by several components.
3.5 Sharing Pins Among Peripherals

Explains that some of the Processors allow few pins to be used or shared by multiple peripherals.

This may lead to the need of sharing pin(s) by multiple components. Normally, if you select one pin in more than one component, a conflict is reported. However, it is possible to setup a sharing for such pin in the component inspector.

One of the components sharing a pin has to be chosen as a main component. This component will initialize the pin. In the properties of other components that use the pin, the pin has to be marked as shared (see figure below).

Pin sharing can be set in the Component Inspector. The Component Inspector must be in EXPERT view mode. Use the pop-up menu of the property and select the command Pin Sharing Enabled.

Pin sharing is advanced usage of the processor peripherals and should be done only by skilled users. Pin sharing allows advanced usage of the pins even on small processor packages and allows application-specific usage of the pins.

3.5.1 ConnectPin Method

It is necessary to invoke the component method ConnectPin to connect a component to the shared pin. It is also necessary to invoke the main component method to connect pin back to the main component. In fact, the peripherals can usually operate simultaneously, but they have no connection to the shared pins unless the ConnectPin method is executed. In case that all components control the shared pin using one peripheral, it is not necessary to use the ConnectPin method.

Shared pins are presented in the Processor View as well. The component to pin connection line is red.
3.6 Export and Import

This topic explains:

- Export Component Settings
- Export Board Configuration
- Import Component Settings
- Apply Board Configuration
- Import Component(s) from Package

3.6.1 Export Component Settings

It is possible to export one or more component settings, such as:

- Configurations
- Operating system
- Processors
- Components

To export component settings:

1. In the IDE, select File > Export. The Export wizard appears.

   Expand Processor Expert tree. Select Export Component Settings option as shown below.
Figure 3-11. Export Wizard

2. Click **Next**. The **Export Processor Expert Component Settings** page appears.
In the left panel, select the project for which you want to export the component settings. In the right panel, select the components to export. Click the **Browse** button to select the output file in which the export settings are saved. The default location for saving the output file is recently selected folder, your home directory. The extension of the file is `.pef`.

3. Click **Finish** to complete the exporting of component settings.

Now you know how to export component settings.

### 3.6.2 Export Board Configuration

It is possible to export one processor and one or more components (the components automatically selected are CPU, Pin settings, LDD, and Init components).
You can save the current state of components related to board configuration into the external file. The extension of the file is `.peb`. The default location for saving the output file is recently selected folder, your home directory.

To export board configuration:

1. In the IDE, select **File > Export**. The **Export** wizard appears.

   Expand **Processor Expert** tree. Select **Export Board Configuration** option as shown below.

   ![Figure 3-13. Export Wizard](image)

2. Click **Next**. The **Expert Processor Expert Board Configuration** page appears.
In the left panel, select the project for which you want to export the board settings. In the right panel, the processor and components are already selected. Click the **Browse** button to select the output file in which the export settings are saved. The default location for saving the output file is either recently selected folder or your home directory. The extension of the file is `.peb`.

3. Click **Finish** to complete the exporting of board configurations.

Now you know how to export board configuration.

### 3.6.3 Import Component Settings

You can import one or more component settings from a file. Although, components with existing name results in conflict, but it is still possible to import. The imported components are added into the selected project.
To import component settings:

1. In the IDE, select **File > Import**. The **Import** wizard appears.
   - Expand **Processor Expert** tree. Select **Import Component Settings** option as shown below.

![Import Wizard](image)

   **Figure 3-15. Import Wizard**

2. Click **Next**. The **Import Component Settings** page appears.
To import component settings from the file to selected project, click the **Browse** button. Select the input file with the `.pef` or `.pe` extension. The default option **Replace settings** is selected if imported component settings are having same name (or ID) and type.

You can select the mode for importing components settings, the options are:

- **Ignore** - do not import this component settings
- **Add new** - add new component with imported settings
- **Add new, keep existing** - if component with same name or type exists, it will add a new component with imported settings and keep the existing one (may cause conflicts)
- **Add new, disable existing** - if component with same name or type exists, it will add a new component with imported settings and disable the existing one
- **Replace settings** - replace existing component with new settings from imported file
- **Click Finish**. The settings from the `.pef` file is imported to the selected project.

### Figure 3-16. Import Component Settings Page

![Import Component Settings Page](image)
You are ready to import component settings.

### 3.6.4 Apply Board Configuration

You can import board configuration from a file. The imported configurations are added into the selected project.

To import board configuration:

1. In the IDE, select **File > Import**. The **Import** wizard appears.

   Expand **Processor Expert** tree. Select **Apply Board Configuration** option as shown below.

![Figure 3-17. Import Wizard](image-url)
2. Click **Next**. The **Apply Board Configuration** page appears.

![Apply Board Configuration Page](image)

**Figure 3-18. Apply Board Configuration Page**

Before importing, you can rename some of the components (as shown in figure above), so it will show the mapping of components with different names, but same device allocation.

To import component settings from the file to selected project, click the **Browse** button. Select the input file with the **.peb** extension. The default option **Replace settings** is selected if imported component settings are having same peripheral device allocation (or ID) and type.

For more information on different types of modes, refer to the **Import Component Settings** topic.

3. Click **Finish**. The settings from the **.peb** file is imported to the selected project.

You are ready to import board configuration.
3.6.5 Import Component(s) from Package

To import a component:

1. In the IDE, select File > Import. The Import wizard appears.

   Expand Processor Expert tree. Select Import Component(s) from Package option as shown below.

   ![Import Wizard](image)

   Figure 3-19. Import Wizard

2. Click Next. The Import Processor Expert Components page appears.
3. Click **Finish** to select and install Processor Expert update packages (.PEUpd) files.

### 3.7 Code Generation and Usage

It explains you about the principles and results of the Processor Expert code generation process and the correct ways and possibilities of using this code in the user application.

In the Project Explorer view, select **ProcessorExpert.pe** and right-click to select **Generate Processor Expert Code Generate Code** option to initiate the code generation process. During this process output files of the components contained in the project are generated. The project must be set-up correctly for successful code generation. If the generation is error free all generated source code files are saved to the destination directory.

#### 3.7.1 Files Produced by Processor Expert
The existence of the files can be conditional to project or Processor Expert environment settings and their usage by the components.

- **Component files**
  Component output files. Refer to the individual component user guides for details about generated output.

- **Signal names**
  This is a simple text file `{projectname}_SIGNALS.txt` or `{projectname}_SIGNALS.doc` with a list of all used signal names. The signal name can be assigned to an allocated pin in the component properties (available in Advanced view mode). This documentation can be found in the Documentation folder of the Components view. Refer to the Signal Names topic for details.

- **Code generation log** that contains information on changes since last code generation.

- **XML documentation** containing the project information and settings of all components in XML format. The generated file `{projectname}_Settings.xml` can be found in the Documentation folder of the Components view. It is updated after each successful code generation.

### 3.7.2 Tracking Changes in Generated Code

Processor Expert allows to track changes in generated modules. It is necessary to enable the option Create code generation log in the Processor Expert Project Options dialog box. Refer to the Processor Expert Options topic for details. If this option is enabled, a file ProcessorExpert_CodeGeneration.txt is generated into Documentation folder.

The file contains a list of changes with details on purpose of each change. Refer to the example below:

**Listing 3-1. Example - Tracking Changes in Generated Code**

```
#############################################################
Code generation 2010/10/22, 15:57; CodeGen: 1 by user:
by Processor Expert 5.00 for Freescale Microcontrollers; PE core 04.46
Configuration: Debug_S08GW64CLH
Target CPU: MC9S08GW64_64; CPUDB ver 3.00.000
# The following code generation options were changed:
> option Create code generation log: value changed from false to true
```

Chapter 3 Using Processor Expert
To view changes within the individual files, you can use a file pop-up menu command Compare with > Local history... available in Components view. It allows to compare files with the version before the code generation.

3.8 PE Project File
All components in the project with their state and settings and all configurations are stored in one file `ProcessorExpert.pe` in the root of project directory. If the whole content of the project including subdirectories is copied or moved to another directory, it is still possible to open and use it in the new location.

### 3.8.1 Project Directory Structure

Processor Expert uses the following sub-directory structure within the project directory:

- **\Generated\_Code** - the directory containing all generated source code modules for components.
- **\Documentation** - the directory with the project documentation files generated by Processor Expert.
- **\Sources** - the directory for main module, event module other user modules.

User-created templates are shared by all users and are stored in the following folder:

- On Windows - `%ALLUSERSPROFILE%\ApplicationData\Processor Expert\{version}\`
  
  For example, C:\Documents and Settings\All Users\ApplicationData\ProcessorExpert\CW08_PE3_02\`

- On Linux - `{workspace}/.metadata/.plugins/com.freescale.processorexpert.core/ProcessorExpert/{version}`

The path is relative to the current Eclipse workspace directory.
Index

A
Apply Board Configuration 57

B
Basic Principles 39
Benefits 8
Build and Debug 39

C
Code Generation and Usage 60
Component Assistant 21
Component Categories 41
Component Inheritance and Component Sharing 46
Component Inspector View 22
Component Sharing 48
Components Library View 19
Components View 15
Concepts 8
Configuration Inspector 28
Configuration Registers View 34
Configurations 43
Configure Components 38
Configuring Components 43
ConnectPin Method 49
Control Buttons 30
Create Project 37
Creating User Component Templates 44

D
Design Time Checking 43
Documentation 46

E
Easy Initialization 40
Easy On-chip Peripherals Management 40
Embedded Components 40
Export and Import 50
Export Board Configuration 52
Export Component Settings 50

F
Features 7
Files Produced by Processor Expert 60
Filtering 20

G
Generate Code 39
Graphical Mode 24

H
Hints 32

I
Import Component(s) from Package 59
Import Component Settings 54
Inheritance 47
Inspector Items 25
Introduction 7
Items Visibility 27

L
Levels of Abstraction 41

M
Main Menu 11
Modes 19

O
On-chip Peripherals 32
Overview 7

P
PE Project File 62
Peripheral or Pin Pop-up Menu 33
Pins 31
Popup Menu 17
Pop-up Menu 20, 24
Preferences 13
Processor Expert Options 12
Processor View 29
Project Directory Structure 63
Project Options 12
Project Pop-up Menu 12
Properties 28

R
Read Only Items 23
Run-time Resources Allocation 48
S
Select Components 37
Settings in Processor Expert 47, 48
Shared Pins 32
Sharing Pins Among Peripherals 49
Signal Names 45
SoC Components 42

T
Tracking Changes in Generated Code 61

U
User Interface 11
Using Processor Expert 37

V
Verify Settings 38
View Menu 17, 23
View Mode Buttons 23
Information in this document is provided solely to enable system and software implementers to use Freescale products. There are no express or implied copyright licenses granted hereunder to design or fabricate any integrated circuits based on the information in this document.

Freescale reserves the right to make changes without further notice to any products herein. Freescale makes no warranty, representation, or guarantee regarding the suitability of its products for any particular purpose, nor does Freescale assume any liability arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation consequential or incidental damages. “Typical” parameters that may be provided in Freescale data sheets and/or specifications can and do vary in different applications, and actual performance may vary over time. All operating parameters, including "Typicals," must be validated for each customer application by customer's technical experts. Freescale does not convey any license under its patent rights nor the rights of others. Freescale sells products pursuant to standard terms and conditions of sale, which can be found at the following address: freescale.com/SalesTermsandConditions.

Freescale, the Freescale logo, AltiVec, C-5, CodeTest, CodeWarrior, ColdFire, ColdFire+, C-Ware, Energy Efficient Solutions logo, Kinetics, mobileGT, PowerQUICC, Processor Expert, QorIQ, Qorivva, StarCore, Symphony, and VortiQa are trademarks of Freescale Semiconductor, Inc., Reg. U.S. Pat. & Tm. Off. Airfast, BeeKit, BeeStack, CoreNet, Flexis, Layerscape, MagniV, MXC, Platform in a Package, QorIQ Qonverge, QUICC Engine, Ready Play, SafeAssure, SafeAssure logo, SMARTMOS, Tower, TurboLink, Vybrid, and Xtrinsic are trademarks of Freescale Semiconductor, Inc. All other product or service names are the property of their respective owners.